Log In   View a printable version of the current page.
  Dashboard > [fleXive] > ... > How-Tos > Upgrading from fleXive 3.1.x

Added by Daniel Lichtenberger, last edited by Anonymous on Dec 21, 2010  (view change)
Labels: 
(None)

Upgrading from [fleXive] 3.1.x

Upgrading to 3.1.4 or later

Applies to versions: 3.1, 3.1.1, 3.1.2, 3.1.3

Due to a change in binary processing you need to make a small fix in a script responsible for rendering PDFs (otherwise PDF previews will be disabled for new contents):

  • Login to the administration GUI as supervisor
  • Go to Administration, Scripts, Overview
  • Look for a file called BinaryProcessor_Documents.gy, open it
  • Replace calls like
    RandomAccessFile raf = new RandomAccessFile((File)binaryFile, "r");

    with

    RandomAccessFile raf = new RandomAccessFile(binaryFile, "r");

    (remove the explicit cast (File)).

Site running on a free Atlassian Confluence Open Source Project License granted to [fleXive] . Evaluate Confluence today.
Powered by Atlassian Confluence, the Enterprise Wiki. (Version: 2.6.1 Build:#916 Nov 09, 2007) - Bug/feature request - Contact Administrators